Scheduled for July 13, 2020 at 5:00 AM – July 12, 2020 at 5:59 PM
- In progress July 13, 2020 at 5:00 AM
- In progress - July 13, 2020 at 5:00 AM- There will be planned downtime as we prepare the service for launch tomorrow! 🎉 
 
- Completed July 12, 2020 at 5:59 PM
- Completed - July 12, 2020 at 5:59 PM- Maintenance has completed successfully!